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Copyright 

Copyright © 2015 Allo. All rights reserved.  

No part of this publication may be copied, distributed, transmitted, transcribed, stored in a 

retrieval system, or translated into any human or computer language without the prior written 

permission of Allo.com. This document has been prepared for use by professional and properly 

trained personnel, and the customer assumes full responsibility when using it. 

Proprietary Rights 

The information in this document is Confidential to Allo and is legally privileged. The information 

and this document are intended solely for the addressee. Use of this document by anyone else for 

any other purpose is unauthorized. If you are not the intended recipient, any disclosure, copying, 

or distribution of this information is prohibited and unlawful. 

Disclaimer 

Information in this document is subject to change without notice and should not be construed as a 

commitment on the part of allo.com. And does not assume any responsibility or make any 

warranty against errors. It may appear in this document and disclaims any implied warranty of 

merchantability or fitness for a particular purpose. 
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About this manual 
This manual describes the Allo product application and explains how to work and use it major 

features. It serves as a means to describe the user interface and how to use it to accomplish 

common tasks. This manual also describes the underlying assumptions and users make the 

underlying data model. 

Document Conventions 
In this manual, certain words are represented in different fonts, typefaces, sizes, and weights. This 

highlighting is systematic; different words are represented in the same style to indicate their 

inclusion in a specific category. Additionally, this document has different strategies to draw User 

attention to certain pieces of information. In order of how critical the information is to your 

system, these items are marked as a note, tip, important, caution, or warning. 

Icon Purpose 

 Note 

 Tip/Best Practice 

 Important 

 Caution 

 Warning 

 
• Bold indicates the name of the menu items, options, dialog boxes, windows and functions. 

• The color blue with underline is used to indicate cross-references and hyperlinks.  

• Numbered Paragraphs - Numbered paragraphs are used to indicate tasks that need to be 

carried out. Text in paragraphs without numbering represents ordinary information. 

• The Courier font indicates a command sequence, file type, URL, Folder/File name  

• e.g. www.allo.com 

Support Information 
Every effort has been made to ensure the accuracy of the document. If you have comments, 

questions, or ideas regarding the document contact online support: http://support.allo.com 

http://www.allo.com/
http://www.allo.com/
http://support.allo.com/
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1. Product Introduction 

1.1 Overview 

The Allo.com’s MegaPBX, a SIP-based, affordable, feature-rich converging communication 

platform designed to meet the communication requirements for small to medium sized 

enterprises. 

The MegaPBX provides the cutting-edge IP-based communications that businesses demand while 

leveraging existing infrastructure and providing a smooth transition into IP telephony. Based on 

open standard SIP, the MegaPBX can easily integrate into and interoperate with other 

components of your existing communications network while providing a rich set of features to 

reduce costs and increase productivity.  

The MegaPBX also includes a Setup wizard and an intuitive user interface that allows users to 

quickly configure extensions, Voicemail, fax mail, Voicemail& fax to email, conference bridges 

and other enhanced features can be turned on with minimal effort via the web configuration 

interface.  

Here, 4 models are available and all supporting up to 200 extensions and 50 simultaneous calls, 

30 people conference room with full features (invite, schedule, email, kick, mute...). FXS ports for 

FAX machines only. 

MegaPBX-PRI supports ISDN PRI protocol and adopts standard T1/E1 trunk interface to realize 

docking with traditional PBX /PSTN. 

Model No - aMP1 

Equipment Packaging 

1) One MegaPBX unit 

2) One 12 Volt power adapter 

3) One Ethernet cable 
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2. Getting Started With MegaPBX 

Initial Setup of IP/PRI/FXS/BRI PBX 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 

 
 

 
 
 
1. Plug one end of the RJ45 Ethernet cable into your Network Switch 

2. Plug the other end of the RJ45 Ethernet cable into the WAN port of the    MegaPBX 

3. Connect a PC to the LAN port of the MegaPBX; Enable the DHCP option in the Network    

Settings of the PC 

4. Plug the Power Adapter included into an available power outlet 

5. Plug the other end of the Power Adapter into the “DC-IN” port of the MegaPBX 

6. The MegaPBX will power up (Boot up time takes about 160secs) 

 Use Straight-through Ethernet cable to connect between the MegaPBX to 

Router/Switch/PC 

 

 

 

 

 

Figure 1: Initial Setup 
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2.1 Hardware Setup 

2.2 Equipment Structure 

MegaPBX-PRI 

 
Figure 2: MegaPBX-PRI 

Interface Description 

Power Connect the power adapter, 12VDC, 3.5A 

Reset Reset button for factory default. 

WAN Standard 10/100BASE-TX Ethernet Interface for WAN 

LAN Standard 10/100BASE-TX Ethernet Interface for LAN 

Memory Card  8GB Storage for voice mails and voice files, IVR 

PRI 1 E1/T1 ports with line link LED indicators ( Orange and Green) 

 

Notification LEDs (On the Front Panel of the Gateway): 
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2.3 Access the web GUI: 

MegaPBX-PRI Web GUI can be accessed either through WAN or LAN interface. Steps to Access the 

GUI during the initial setup through LAN interface: 

1. Make the setup as mentioned in the hardware setup 

2. Change the Network setting of the PC is set in automatic mode (i.e. DHCP mode). An IP 

address will be accessed to the PC in manual mode (i.e. Static IP mode). Assign the IP 

address to the PC in the range of 192.168.113.xxx series (E.g:192.168.113.10), net mask as 

255.255.255.0 and gateway & DNS as 192.168.113.1. 

3. Launch the web browser and enter the URL http://192.168.113.2 (Default LAN IP address) 

to open the login page of MegaPBX-PRI Graphical Interface. 

 
Figure 3: Login Page 

 
4. Login using the default username & password (Default: Username: admin; Password: 

admin). Successful login takes you to the Dashboard page. Observe the WAN IP address on 

the dashboard, this will be used to access the GUI from the WAN interface. 

After successful login we get a MegaPBX-PRI Home Dash Board. To guarantee the system safety, 

When login for the first time, we need to modify Password. For modifying the password go to 

TOOLS->Admin Account Option 

 

http://www.allo.com/
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The Recommended web Browser to access GUI is Mozilla Firefox only. 

If your network is not enabled with DHCP server, configure the WAN port IP address manually in 

the SETTINGS > Network Settings section as per your requirement. 

WARRANTY  

Hardware Warranty: 1 year 

If the MegaPBX PRI was purchased from a Distributor/reseller, please contact the company where 

the device was purchased for replacement, repair or refund. If the device was purchased directly 

from Allo.com, contact our Technical Support Team for a RMA (Return Materials Authorization) 

number before the product is returned. Allo.com reserves the right to remedy warranty policy 

without prior notification. 

  Use the power adapter provided with the ALLO MegaPBX PRI. Do not use a different power 

adapter as this may damage the device. This type of damage is not covered under warranty. 
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3. Setting up Features 
 
Setting up your browser for working with MegaPBX-PRI is simple. In order to run this application 

appropriately the following settings are to be configured. 

3.1 System Dashboard 
ALLO MegaPBX-PRI Dash Board summarizes the MegaPBX-PRI status with a graphical display. 

Detailed status of an individual entity is available under the Status Tab or it can be directly 

accessed by clicking on more. 

 

Figure 4: SIP Status 

 Please change the default administrator password to alphanumeric, to prevent hacking. 
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4. Setup 
4.1Extensions 
Here, user can configure Feature (*) Code for different Call Features. 

4.1.1 SIP Extensions 
Navigate through Setup > Extensions > SIP Extensions 

SIP Extensions are the unique number mapped to person that can be reached and be able to place 

calls. 

 
Figure 5: SIP Extensions 

Click Add New, to create an Extension 

http://www.allo.com/
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Figure 6: Create an Extension 

 
Figure 7: Create Range 

Extn Number Extension Number of endpoint (e.g.: IP phone) will use to 

authenticate with the MegaPBX, eg: 4000.   

First Name A character based first name for the user eg:”Bob”. 
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Last Name A character based last name for the user eg:”Jones”. 

Email E-mail address for the user eg:”Bobjones@xyz.com”. 

Password Password used to authenticate your phone and voicemail pin. 

Extension Settings This allows the user to either enable or disable email alerts or 

message waiting indication. 

Add Extension Range Range of Extensions can be added at once with required voicemail 

settings, Eg: from 4000 to 4010. 

Show/ Hide Advance Options 

Advance options, allows enabling the Features, Codec Configuration and Dialout Settings for a 

specific user. Default SIP group is disabled when Advanced Options is enabled. 

 Advanced Options 

DTMF Set default DTMF mode for sending DTMF digits. Options:  

• INBAND – sent along with audio (requires 64 kbit codec 

- alaw, ulaw) 

• INFO – sent as SIP INFO messages 

• RFC2833 – sent as RTP packets  

• AUTO – System automatic selects the mode. Uses 

RFC2833 if offered, inband otherwise. 

Default: AUTO  

Features Enable or Disable the desired features like voicemail, call queue, 

conference, and call back, call pickup, call park, etc… 

Codec Configuration Choose the available Codecs and set priority in the order in which 

Mega PBX should prefer to send and receive audio. Supported 

codecs are alaw, ulaw, G.729, G.722 

Dialout Settings Allow or deny the preferred dial out plans for user. 

 

 

 

http://www.allo.com/


 

 MegaPBX PRI User Manual                                                                                                                              
 

www.allo.com                                                                   Version 2.0                                                               16 
 

4.1.2 SIP Extension Group 

Navigate through Setup > Extensions > SIP Extension Group 

 By Default there is an extension group called “Default SIP”. You can limit or enable PBX features 

for extensions by creating Extensions group. 

 
Figure 8: SIP Extension Group 

 
Figure 9: Create Extension Group 
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Group Name Descriptive name for extension group 

DTMF Set default DTMF mode for sending DTMF digits. Options:  

• INBAND – sent along with audio (requires 64 kbit codec - 

alaw, ulaw) 

• INFO – sent as SIP INFO messages 

• RFC2833 – sent as RTP packets  

• AUTO – System automatic selects the mode. Uses 

RFC2833 if offered, inband otherwise. 

Default: AUTO  

Features Enable or Disable the desired features like voicemail, call queue, 

conference, and callback, call pickup, call park etc… 

Codec Configuration Choose the available Codecs and set priority in the order in which 

Mega PBX should prefer to send and receive audio. Supported codecs 

are alaw, ulaw, G.729, G.722. 

Dialout Settings Allow or deny the preferred dial out plans for this extension group. 

4.2 Trunks 

4.2.1 SIP Trunks 

Navigate through Setup >Trunks > SIP Trunks 

 SIP Trunks provide the interface to any SIP companion such as VoIP service provider, any SIP 

server or SIP clients. Add different types of interfaces, and configure the signaling & media settings 

for each trunk. 

http://www.allo.com/
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Figure 10: SIP Trunks 

 
Figure 11: Create SIP Trunk 
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 Account Name  Descriptive name for the SIP Trunk for user's reference. e.g.: 

5656. 

Username  Username of endpoint (e.g.: IPPBX) will use to authenticate with 

the Mega PBX, e.g.: 5656 

Proxy Address IP address or hostname with port of the endpoint (VOIP Service 

Provider or IPPBX) where the calls will be diverted. Default port 

no.: 5060, e.g.: 192.168.0.100. 

Outbound Proxy Address  IP address or hostname with port of the outbound proxy server. 

This ensures that all the SIP packets are sent via specified proxy. 

Specifying the port is not mandatory. Default port no.: 5060  

e.g.: 192.168.0.222:5062 OR 192.168.0.222 

Authentication Enable, if Authentication is required by the End point (VOIP 

Service Provider or IPPBX) 

Auth. Username A username to use only for registration. e.g.: 5656. 

Password  Password to authenticate registrations and inbound & 

outbound calls. 

Registration Mode Enable, if Registration to the End point (VOIP Service Provider or 

IPPBX) is required. 

Registrar Address IP address or hostname with port of the Registrar server where 

Mega PBX must register to. Specifying the port is not 

mandatory. Default port no.: 5060  

e.g.: 192.168.0.222:5062 OR 192.168.0.222 

Bridge PIN  You can set a PIN for outgoing calls on SIP trunk, thus you will 

set one more level of security. Leave it blank for unsecured 

mode. E.g.: 111. 

Inbound Call Handling Route incoming calls to any destination like extension, queue, 

and voice mail group, IVR, conference, DID Extensions etc. 

E.g.: Route To Extension 2000. 
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 Show/ Hide Advance Options 

 Advance options, allows enabling the options like Features, Codec Configuration and Dial out 

Settings for a specific Trunk. 

 Advanced Options 

DTMF Set default DTMF mode for sending DTMF digits. Options:  

• INBAND – sent along with audio (requires 64 kbit 

codec - alaw, ulaw) 

• INFO – sent as SIP INFO messages 

• RFC2833 – sent as RTP packets  

• AUTO – System automatic selects the mode. Uses 

RFC2833 if offered, inband otherwise. 

Default: AUTO  

Registration Timeout You can set the length of time in seconds between registration 

attempts (the default is 20 seconds). 

Features Enable or Disable the desired features like NAT, FAX, DID 

Routing, video calling and call recording. 

Codec Configuration Choose the available Codecs and set priority in the order in 

which gateway should prefer to send and receive 

audio. Supported codecs are alaw, ulaw, G.729, G.722 

 

4.2.2 PRI Trunks 

(Only for Mega PBX products with PRI support) 

Navigate through Setup > Trunks > PRI Trunks 

PRI Trunks provides the interface to any ISDN PRI companion such as PRI service provider or any 

other ISDN PBX. Create an interface for each span. 
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Figure 12: PRI Trunks 

 
Figure 13: Create PRI Trunk 

Span Name Select the appropriate PRI Spans. 

Trunk Name Descriptive name for the PRI Trunk for user’s reference. 

Bridge PIN You can set a PIN for outgoing call on PRI trunks, thus you can set 
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one level of security. Leave it blank for unsecured mode. 

Outbound Caller ID Configure the Caller ID Number that would be applied for 

outbound calls over this trunk. 

Inbound Call Handling Route incoming calls to DID extensions or Dial out rules. Route-1 

and route-2 can be defined. E.g.: Route-1: DID Extension pattern: 

1X.  Trim Digits : 0.  

DID Routing Enable or Disable the DID Routing for this trunk 

 

4.3 DID Routing 

Navigate through Setup >DID Routing 

 DID Routing is a feature that enables incoming calls to be routed directly to the selected 

extension or trunk. 

 
Figure 14: DID Routing 

DID Number It is the number provided by the service provider for the 

incoming calls. e.g.: 5023 

Route To Specify where the incoming calls should be routed. 

e.g.: Conference. 

ADD DID Range Here you can specify the range of the DID numbers provided 

by the service provider, e.g.: 5000 to 5010. 
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Start Extension to Map Here you can specify the starting number of the SIP extension 

which is to be mapped with the DID numbers. e.g.:2000 
  

 
Figure 15: Add a new DID 

 
Figure 16: Create DID Range 

4.4 Dial-out Rules 
Navigate through Setup > Dial-Out Rules 

Dial out Rules is used to configure the system to judge outgoing calls via trunks and also used to 

select a least cost routing provider based on the prefix configured. 
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Figure 17: Dial-Out Rules 

 
Figure 18: Create Dial-Out Rule 
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Name Descriptive name for the Dial-Out rule for user's reference. 

Description Provide the description for the Dial-Out rule. (Optional) 

Pattern Specify the pattern to match the dialed string of the incoming call.  

Pattern: 

X: Any Digit from 0-9.  

Z: Any Digit from 1-9. 

[12345-9]: Any digit from 1 to 9.   

N: Any Digit from 2-9.  

".": Wildcard. Match one or more characters.  

"!": Wildcard. Match zero or more characters immediately.  

e.g.: X. – match at least one digit 

        988XXXX – match 988 followed by 4 digits 

Enable Ceasing Trunk Seize the line and dial out. 

Trim Digits Number of digits to trim from the beginning of dialed number. Eg. 

Pattern=52xx , Trim Digits=1, dial out digits = 2xx 

Prepend Digits Entered digits add to the beginning of pattern to be Dialout. 

Outbound Call Route Select the preferred trunks where calls are to be routed for this Dial 

Out rule. Ordering of the trunks in the “Selected” column indicates 

the order in which call flows on failure. 

 

4.5 Time -based Routing 

Navigate through Setup > Time-Based Routing Groups 

 Time-base routing, routes calls to different locations based on the time of day and day of 

week, when a call is made.  
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Figure 19: Time-based Routing Groups 

 
Figure 20: Create Time route Groups 

Group Name Descriptive name for the Time-Based Routing Group for user's 

reference. 

Description Provide the proper description for the Time based routing rule. 

(Optional) 
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Route Type Select the destination where the call is routed to on matching 

the time. The destination can be any of these – Extension, 

Trunk, IVR, Queue, Voicemail Group, Fax to E-Mail 

Route To  Setting the destination for the incoming route. The destination 

can be any of   the created extensions, Trunks, IVRs, Queues 

and so on. 

Duration Specify the time range for which this routing rule will apply. 

Format: hh:mm 

Days Select the day/days during which this routing rule will apply. 

Make sure that the current date and time are configured correctly under System> 

Date/Time Configuration. 
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5. Features 

5.1 IVR 
Navigate through Features >IVR 

Interactive voice response is a pre recorded interactive operator that allows an automatic 

separation of the incoming calls through the sequence of interaction with a multiple choices of 

menu with telephone callers. 

 
 Figure 21: IVR (Interactive Voice Response)  
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Figure 22: Create IVR 

 IVR Name A character based name for the IVR. 

Description Detailed description of the IVR. 

Sequence Association Specifying how incoming calling should be handled 

sequentially. 

Sequence List List of operations to be handled. 

5.2 Voice Files 
Navigate through Features > Voice Files 

 Voice files are the audio files that are going to be played during the IVR play back and these files 

can be uploaded or they can be recorded, the user also has an option to associate key press with 

his voice file. 
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Figure 23: Voice Files 

 Example 1: Voice file without Key press 

“Welcome to Allo.com! If you know your party’s extension, please dial it now. 

Example 2: Voice file with Key press 

Press 1 for Customer Service 

Press 2 for Sales 

Press 0 for Reception 
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Figure 24: Create Voice file 

File Name A character based name for a voice file. 

Description Detailed description for the voice file. 

File Upload Upload the voice file to device. 

Key Association With associated key press option it will route incoming call to 

the specified destination. 

Associated Keys The sequence in which a key and its associated action is given. 

  Mega PBX Supports”.wav” format only 
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5.3 Conference 

Navigate through Features > Conference 

 The Mega PBX supports password protected conference bridges that allow up to 50 

simultaneous participants from any trunks or Internal Extensions. 

 Conference Number Specifies a unique number which can be used to enter the 

conference room, e.g.: 6000. 

Date Specifies the date when the conference has to be scheduled, 

e.g.: 26/2/2014. 

Start Time Specifies the time to schedule the conference. E.g.: 12:30. 

Duration The duration during which the conference will be active, e.g.: 

180 minutes. 

Admin Pin Specifies the PIN for the admin user to join the conference, e.g.: 

555. 

Speaker Pin  Specifies the PIN for the speaker and this user can speak and 

listen, e.g.: 666. 

Listener Pin Specifies the PIN for the listener and this user can only listen 

but cannot speak, e.g.: 777. 

Participants Specifies the privilege to be assigned and it can be Admin, 

Speaker or Listener. 

Add Dynamic Participants This option enables the user to add the participants 

dynamically from the web GUI. 

Outbound Dialing This option enables the user to add the participants 

dynamically over the trunks. 

Maximum Participants Specify the maximum participants to be allowed, e.g.: 10. 

5.4 Call Queues 
Navigate through Features > Call Queues 

 Call Queues are used to distribute calls in the order of arrival to the first available agent. The 

system answers each call immediately and if necessary holds it in a queue until it can be directed 

to the next available agent. This feature is used to balance the workload among the agents. 
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Figure 25: Call Queues 

 
Figure 26: Create New Call Queue 

 Queue Name A character based unique name for the queue. 

Strategy Calls are distributed among the members handling a queue 
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with one of the several strategies like Ring all, Round robin, 

Random etc.,. 

Description Detailed description of the queue. 

Queue Length Used to decide the length of the queue. 

Queue Members Add the members to distribute the incoming calls. 

Announcement Options You can set timeout for queue, member and wrap up. 

5.5 Voicemail Groups 

Navigate through Features > Voicemail Groups 

 Voicemail Groups feature allows sending the voice message to multiple people or a group of 

people. 

 
Figure 27: Voicemail Groups 
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Figure 28: Create New Voicemail group 

 

 Group Name A character based unique name for a voicemail Group 

Description Detailed description of the Voicemail Group. 

Members Specifies the members to receive the voicemail from the list of 

available members. 

 

5.6 Directory Entries 

Navigate through Features > Directory Service 

 Directory is where you can configure the Directory option for the extensions to search users by 

their First or last name. Dialing the 'Directory Extension' would present to the caller, a directory of 

users listed in the system telephone directory - from which they can search by First or Last Name.  
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Figure 29: Directory Entries 

 Extension Number Specify the Extension number to dial for accessing the Name 

Directory, e.g.: 555. 

First Name Allow the caller to enter the first name of a user in the 

directory, e.g.: JOHN. 

Last Name Allow the caller to enter the Last name of a user in the 

directory, e.g.: RAJ. 

Import Directory Import the directory entries by browsing the corresponding 

file. File has to be in .CSV format. 

Export Directory Export the Directory Entries by specifying the filename. The 

File will be exported to the local computer in .CSV format 
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6. Advanced 

6.1 Feature Settings 

Navigate through Advanced > Feature Settings 

Feature Settings allows to modify the basic call related functionalities like call pickup, Conference, 

Callback etc… 

6.1.1 Extension 

 

Figure 30: Feature Settings 

 Pickup  

  

This feature code is to pick up the ringing extension from 

another extension if the party is not available in the desk. By 

Default Feature code is “*9”. For e.g. if *9 is your call pick up 

code, by dialing *91002 from any other extension you can 

attend 1002 phone extension. 

Conference 

  

Using this feature code you can enter into the conference 

room. By Default the Feature code is “*900”, i.e. Dial *900 

from your phone and It will prompt you for the Conference 

Number and the PIN and it will let you enter into the 

conference room. 

Dynamic conference 

  

Using this feature code you can enter into the conference 

room and also add users in to it. By Default the Feature code 

is “*901”, i.e. Dial *901 from your phone. It will prompt you 
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for the Conference Number and the PIN and it will let you 

enter into the conference room. To add users into the 

conference *0 then followed by extensions. 

Voicemail This is to assign the code for accessing the voice mail. This will 

allow end users to change their personal settings for voice 

mail handling. By dialing to this number, any users who are 

registered to Mega PBX can access the Voice Mail. I.e. dial 

*800 from your phone and follow the instructions. 

Directory Using this Feature code you can dial the other extension with 

first and last name configured in the PBX. 

6.1.2 Voicemail 

 

Figure 31: Voicemail 

 Enable Voice mail 

  

With voice mail, callers can leave messages when you are 

busy, unable to answer phone calls, or when the IP phone is 

off-line. 

Enable Email alerts on new 

Voicemail 

Helps to send an email when someone leaves a voice 

message. 

Enable Voicemail 

attachments in Email alerts 

Helps to attach voicemails in your Emails. 

Enable Voicemail access Helps to access your voicemail by using the voicemail access 
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number followed by the password. 

Enable message waiting 

indication 

Helps the subscribers to know that a voice message is 

waiting. 

Customized Voicemail 

message 

Allows you to customize the Voicemail message Notifications, 

which will be sent to the specified Email-ID’s. 

6.1.3 Call Park 

 

Figure 32: Call Park 

 Parking 

  

Using this feature code you can park the number of calls. By 

Default the Feature code is “*700”. i.e. park a caller by dialing 

*700 by using transfer button on your phone 

Parked 

  

Using this feature code you can retrieve the parked calls. By 

Default the Feature code is “*701. To retrieve the call, the 

user can go to any phone in the group and press the feature 

code “*701” and dial the parked extension. 

Number of slots 

  

Specifies the number of parking slots. 

For example, to configure six parking slots : (701, 702, 703, 

704, 705, and 706) 

Timeout It is the timeout interval for calls parked at a call-park slot. 
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6.1.4 Call Back 

 

Figure 33: Callback 

Callback prefix To register callback function, user has to dial destination 

number with this prefix code. 

Retry Options This option helps to callback with number of attempts and 

timeout for the callback and also the time interval between 

callback calls. 

6.1.5 FAX 

 
Figure 34: Fax 
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Fax to Email format Specify the format to receive the FAX by email either PDF or 

TIFF format. 

Customized Fax message Allows you to customize the FAX message Notifications, which 

will be sent to the specified Email-ID’s. 

 6.1.6 Conference 

 

Figure 35: Conference 

Customized conference 

message 

Allows you to customize the Conference message 

Notifications, which will be sent to the specified Email-ID’s. 

 

 6.1.7 Voice Prompts 

 
Figure 36: Voice Prompts 

Select language for Voice- Allows you to select the language for the Voice prompts. 
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prompts. MegaPBX- BRI supports four language voice prompts such as 

English, French, Turkish, and Spanish. 

6.2 ISDN PRI Settings 
(Only for Mega PBX products with PRI support) 

Navigate through Advanced > ISDN PRI Settings 

This section provides the ability to modify the PRI settings depending on the carrier (T1/E1), 

signaling, switch type, etc with respect to the service provider or any other mate.  

 
Figure 37: ISDN PRI Settings 

 
Figure 38: Advanced PRI Settings 

Framing/Coding Select Proper Framing & coding by checking with your service 

Provider. If CRC is enabled from Telco side, Please select 

CCS/HDB3/CRC4. If not select CCS/HDB3. 
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Default for E1: CCS/HDB3 

Default for T1: ESF/B8ZF 

Signaling Select if gateway should work as customer premises equipment 

(CPE) or network device (NET). If Gateway is connecting to PRI 

service provider, select PRI-CPE. If connected with other Digital 

PBX’s configured as CPE, then select PRI-NET.  

Default: PRI-CPE 

Switch Type Select the switch type as indicated by the ISDN service provider. 

Default: E1- Euro ISDN & T1- National ISDN2 

Sync/Clock Source Specify a transmit clock source. Master clocking uses the device’s 

own system clock. Primary or secondary clocking uses a signal 

received from the T1 or E1 interface.  

Default: Master 

Line Build Out LBO depends on the line length for which attenuation is defined. 

Default: 0db. Check with your service provider for appropriate Line 

build out settings if you face any issue. 

Channels Indicate the number of channels to be used on this span. 

Advanced Options 

Dialed Numbering 

Plan 

ISDN-level Type Of Number (TON) or numbering plan, used for the 

dialed number, which is dependant on geographical location. 

Default: unknown 

Dialing Numbering 

Plan 

Sets the calling number's numbering plan. Default: National 

Prefix Prefixes specified under international, national, private, local, and 

unknown, will be used with dynamic dialing numbering plan, which 

dynamically sets the Type Of Number in the ISDN messages. If the 

called number matches the national prefix specified, it will 

automatically set the ISDN TON of calling number to national. 

Similarly for international & local prefixes. This will also strip off the 

digits in the prefix from the called number as well, but only if 

national or international prefix is matched. 
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Overlap Dialing Send overlap digits 

 

 

Advanced PRI settings 

Span Type Select the carrier type, E-carrier (E1) or T-carrier (T1) which 

depended on lines provided in your country. Default: E1 

Enable Progress 

indication 

Enabling this will provided call progress tones. Required, if service 

provided fails to provide call progress tones.  

 

6.3 SIP Global Settings 

Navigate through Advanced > SIP Global Settings 

 SIP Global settings apply to all VoIP traffic.  

6.3.1 Port Settings 

 

Figure 39: Port Settings 

SIP Bind Port Choose a port on which to listen for SIP UDP traffic. Default: 

5060 

RTP Port Range Range of port numbers to be used for RTP traffic.  

Default: 16001- 17000 

Make sure you configure this dynamic range of ports on 

your NAT Router. When the Mega PBX is behind a NAT and 
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the NAT is configured to do port forwarding with above 

mentioned port range for UDP ports. 

UDPTL Port Range Port range for T38 Faxing is 17001 to 18000. 

 

6.3.2 NAT Settings 

 

Figure 40: NAT Settings 

NAT NAT option is checked, when the Mega PBX is behind the 

Router/Firewall. Select either Stun Server IP or External IP. 

Default: disabled 

Stun Server IP If the Mega PBX is behind a non-symmetric NAT router, it 

may be necessary to use STUN to allow PBX to reliably 

communicate via IP through the router. Enter a STUN 

server IP address or domain name in the STUN Server field. 

For a list of public STUN servers, please Refer to: 

http://www.voip-info.org/wiki/view/STUN 

External IP Enter the NAT Traversal IP address i.e. Public IP Address of 

your internet, to communicate with Public   Network when 

PBX is behind the NAT. This IP address will substitute in all 

outgoing SIP messages instead of Local IP address. 

Local Netmask Entering the Net mask of the local network of the Mega 

PBX allows it to identify the hosts falling within the same 
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network. E.g.: 192.168.2.0/255.255.255.0 

6.3.3 Registration Timer 

 

Figure 41: Registration Timer 

Default Registration Expiry Default duration (in seconds) of incoming/outgoing 

registrations. Default: 120 sec 

Min Registration Expiry Minimum duration (in seconds) of registrations allowed 

by the Mega PBX. Default: 60 sec 

Maximum Registration Expiry Maximum duration (in seconds) of incoming registrations 

allowed by the Mega PBX. Default: 3600 sec 

Registration Attempts Number of registration attempts before giving up with 

registrar (Outbound Registrations only).  

Default: 0 (never give up) 

Registration Timeout Registration attempt will be retried till this duration (in 

seconds), if no response from the Registrar. (Outbound 

Registrations only). Default: 20 sec 

 

http://www.allo.com/


 

 MegaPBX PRI User Manual                                                                                                                              
 

www.allo.com                                                                   Version 2.0                                                               47 
 

6.3.4 Call Recording 

 

Figure 42: Call Recording 

Server Address It enables Call Recording with the given server where the 

ORK audio application is running. 

 

6.4 CDR Settings 
Navigate through Advanced > CDR Settings 

CDR Settings feature allows managing the call records via radius server and FTP server. 

6.4.1 Radius Configuration 

Radius Server Configuration allows configuring the radius server information where all the call 

records will be saved in the form of vendor-specific attributes (VSAs). 

 
Figure 43: Radius Configuration 
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To upload CDR entries via Radius, we need to install Radius Server on PC and the same has to be 

configuring it. 

Server IP Address User can enter the IP Address of Radius Server. Ex: 

192.168.xxx.xxx 

Server Port It specifies the Port Number on which Radius Server can be 

connected. By default Radius Server works on 1813 Port. It 

can be changed depending upon Radius Server's 

Configuration. 

Password User can enter the Radius Server's password to 

authenticate the Radius configuration. 

Radius VSA Attrib MegaPBX supports two attributes such as CISCO, DIGIUM. 

User can select anyone from the drop down list.  

Radius Retry Count It specifies No. of retries to upload CDR entries to Radius 

Server. 

Radius Retransmission Interval It specifies the time duration between retries. 

 

Note: User can use secondary Radius Server. 

6.4.2 FTP Configuration 

This will allow you to configure the FTP server information for CDR billing and CDR upload 

scheduling by setting the Frequency of schedule, Day and Time. 

 
Figure 44: FTP Configuration 
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Figure 45: Upload Records 

 

Server IP address User can enter the IP Address of Radius Server. Ex: 

192.168.xxx.xxx 

Server Port It specifies the Port Number on which Radius Server can 

be connected. By default Radius Server works on 1813 

Port. It can be changed depending upon Radius Server's 

Configuration. 

Username It specifies the username of endpoint (e.g.: IPPBX) will use 

to authenticate with the Mega PBX, e.g.: 5656 

Password User can enter the Radius Server's password to 

authenticate the FTP Configuration Settings. 

Schedule A user can schedule uploading CDR entries to FTP server. 

There are three frequency options: Daily, Weekly and 

Monthly. 

6.4.3 Upload History 

It shows the upload history of CDR with the details like time, server address and status of the 

uploaded CDR. 
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Figure 46: Upload History 
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7. System 

7.1 Network 
Navigate through System > Network Settings 

 Network Settings allows modifying the device network settings. 

 
Figure 47: Network Settings 

 WAN Configuration: 

DHCP When enabled and a DHCP server is available, the Mega PBX will 

auto configure itself. If DHCP server is not available, select “Static”, 

and fill in the Network Configuration. 

IP Address The static IP address corresponding to your WAN configuration. 

Net mask The Net mask corresponding to your WAN configuration. 

DNS  The IP address corresponding to a DNS server. 

 

 LAN Configuration: 

LAN Port is a management port. Mega PBX can be connected back-to-back to a PC or to a LAN 

network for configuration. It is always recommended to connect back-to-back to a PC. In case, 

connected to LAN network & if IP series clash is found, IP series can be changed here. 

 WAN port IP address and LAN port IP address should not be in the same network segment. 
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Media Configuration: 

 It is applicable only for 4. 0.0 Version onwards. If the media IP address is not configured, 

there won’t be voice path in the calls. 

Media IP Address needs to be configured manually and it should be in the same network 

segment of WAN IP address. This IP address is used for Voice Media Configuration. 

For E.g.:  If the WAN IP address is 192.168.0.145 and media IP address should be in the same 

Network Segment (available IP address) side. 192.168.0.3 

 
Figure 48: Warning 

  System will reboot to apply the network changes. 

Host Configuration: 

Host name: Label or IP of your system identity. 

7.2 Date/Time 

Navigate through System > Date/Time 
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 Configuration Type Date and Time of the Mega PBX can be either set manually (uses 

RTC) or automatically (through NTP). Default: NTP 

NTP Configuration Time Zone: Select the correct time zone for the location where 

the Mega PBX is installed using the Time Zone dropdown box. 

Default: Asia/Kolkata 

NTP Server: URI or IP address of the NTP (Network Time 

Protocol) server, which will be used to synchronize the date and 

time. E.g.: 3.in.pool.ntp.org 

 

Click on “APPLY “button, followed by “SAVE ALL” button to update the configuration changes. 

 

 Changing the configuration requires the current calls to be disconnected. 
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8. Tools 
8.1 Diagnostics 

Navigate through Tools > Diagnostics 

 Analyze the functionality of the Mega PBX with some of these diagnostic tools provided. 

 
Figure 49: Diagnostics 

 Ping Test:  

It is used to check the packet loss and latency time from your SIP end client like IP Phone/ FXS 

gateways to check the quality of your network connections.  

 
 
 

 Trace route Test: It is used to determine the route taken by packets across an IP network. 

Figure 50: Diagnostics Result 
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Figure 51: Diagnostics Result 

 Format SD Card / Format USB Drive: This will allow you to completely erase all the contents in 

the SD card/ USB Drive (MegaPBX-BRI supports USB Drive).   

  If you are formatting the USB Drive/SD card details, kindly take the back of the MegaPBX 

configuration. 

8.2 Backup/Restore 
Navigate through Tools > Backup/Restore 

Back Up: 

Allow you to take the back up of the System configurations & save it to the local PC. 

 Restore: 

Restoring from a new upload or backup file will destroy all current configurations and require a 

system reboot.  All calls will be dropped and all current configurations will be destroyed. 

 
Figure 52: Backup/Restore 
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 Administrator password will not be restored on restoration. So you should still use same 

credentials as before restoration. 

8.3 Upgrade Firmware 

Navigate through Tools > Upgrade Firmware 

 Update Mega PBX with the latest release available, which can contain key updates, added 

functionalities and bug fixes. When a new release is available, download it and save to your local 

PC. Then, browse for the file, and click the Upload button. Now your Mega PBX will display a 

Progress Screen and will prompt when it is about to reboot. Reboot and wait for blue LED’s turn 

ON. 

 
Figure 53: Upgrade Firmware 

During firmware upgrade, there should not be any power or network disturbances, which 

may leads to Mega PBX board faulty. Firmware up-gradation process will take few minutes. 
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9. Status 
This section generates the various status of the MegaPBX-PRI are explained below. 

9.1 Call Reports 
Navigate through Status > Call Reports 

Call Reports displays a detailed list of calls pass through the MegaPBX-PRI. The list can be 

generated on the bases of date range, CDR count, latest 50 entries or all entries. Generated report 

can also be exported to local PC as CSV file or directed to a printer.  

To create a new Report, select the Extension Range or Date range, and click the “Generate” 

Report button. A list with call details will display in the Call Reports section. 

You can either export to your local PC or Print the Call reports. 

 
Figure 54: Call Reports 

9.2 SIP Station 
Navigate through Status > Call Reports 

 SIP Station Status page displays detailed status of each SIP Extensions available on the MegaPBX-

PRI.  

 E.g.: 

No. Extension Host Status 

1 1001 Unspecified Registration Failed 

2 1002 192.168.0.127 Registered 
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Figure 55: SIP Station Status 

9.3 SIP Trunks 
Navigation: Status > SIP Trunks  

 SIP Trunk Status page displays detailed status of each SIP trunks available on the MegaPBX-PRI.  

 
Figure 56: SIP Trunks Status 

Status Reg. State Description  

OK Registered Configured, Registered & 

reachable 

- 

OK - Configured & Reachable, but - 
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no Registration 

OK Request 

Sent 

Configured, but Host not 

responding or unreachable 

Check Registrar 

Address 

OK Rejected Configured & reachable, but 

Registration failure 

Check 

Authentication 

UNREACHABLE Registered Configured, Registered, but 

not reachable 

Check Proxy Address 

UNREACHABLE - Configured, but not reachable Check Proxy Address 

UNKNOWN - Not Registered Client not registered 

 Dynamic: Host IP is obtained dynamically on registration. 

9.4 PRI Span 
(Only for Mega PBX products with PRI support) 

Navigate through Status > PRI Span 
 
PRI Span Status page displays detail status of each E1/T1 Port with individual channel info, 

available on the PRI Gateway.  

 
Figure 57: PRI Span Status 
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E1/T1 Port Status Description 

 

 
 

 

Appliance is not seeing far end, circuit is not up, or cable is bad. 

 

 
 

 
Appliance is synchronizing or is receiving a yellow alarm from the 
far end. 

 

 
 

 
PRI Link is Active. Appliance is in-sync with the far end. 

 

 
 

 
T1/E1 driver is not initialized or device undetected. 

 

Channel Status Description 

 

 
 

 
Channel is Busy 

 

 
 

 
Channel is Idle and ready to receive or make calls 

 

 
 

 
Channel is not active 

9.5 Current calls 
 Navigate through Status > Current Calls 

 Current Calls page displays detailed status of the real time calls available on Mega PBX. 

9.6 Current Conferences 
Navigate through Status > Current Conferences 

Current Conferences page displays detailed status of the real time conference available on Mega 

PBX. 

9.7 Network 
Navigate through Status > Network Status 

 Network Status page displays detailed status of the network configuration on Mega PBX.  
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10. Administrator 

 

Figure 58: Administrator 

10.1 Reboot 

 Navigate through  > Reboot 

Using this option administrator can reboot (SOFT reboot) MegaPBX System remotely 

10.2 Call Manager Reload 

 Navigate through  > Call Manager Reload 

Reloading Call Manager will restart call manager and drop all current calls. 

10.3 Web Settings 

  Navigate through  > Web Settings 

 Session Timeout Duration after which current web login session expires. Default: 

3600 sec 

Pagination Number of entries in a table per page to be displayed. 

Change Password Modify Administrator password here. 

  

10.4 Email Settings 

 Navigate through  > Email Settings 

 To configure the Mega PBX to send out voicemail/FAX via email, the related SMTP setting must be 

configured. 
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 Mail Server Enter the domain name of the Email Server address of the 

particular authorized email client account  

Email ID Enter the email ID of the particular authorized email client 

account. 

Username  Email ID given by the Mail Server administrator. 

Password Password of the Email ID 

TLS Support 

  

To secure the server to server transfer of emails, the provider 

needs to enable a technology called Transport Layer Security 

(TLS). 

 

10.5 Logout 

 Navigate through  > Logout 

Administrator Logout option after use. 
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