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Box Contents 
 
1. MicroPBX Unit 
2. 1GB Flash Card (installed) 
3. 256MB RAM (installed) 
4. Power Adapter 
5. Power Cable 
6. RJ45 Ethernet Cable 
 

 
 
 
 
 
1. Installation 
 

• Step 1: Plug one end of the RJ45 Ethernet cable into your Switch / Router 
• Step 2: Plug the other end of the RJ45 Ethernet cable into the LAN1 port of the MicroPBX 
• Step 3: Plug the Power Cable into the Power Adapter. Plug the Power Cable into an available power outlet 
• Step 4: Plug the Power Adapter into the “DC-IN” port of the MicroPBX 
• Step 5: Turn on the Power Switch at the back of the MicroPBX 
• Step 6: Configure your MicroPBX according to the instructions below 

 
2. VoIP Configuration 
 
2.1 Getting the IP Address 
 
There are three (3) ways of getting the IP address of your MicroPBX: 
 

1. Plug a screen to the MicroPBX, turn it on and when it finishes loading, it will display the IP address. 
 
2. Getting the IP provisioned to the MicroPBX by checking the DHCP Server Logs on the network. 
 
3. Connect a laptop with a Crossover cable to the LAN2 port of the MicroPBX and access the MicroPBX GUI 
by going to IP address: http://10.0.0.1 ; Log into the interface with admin / admin and go to the Status page. 
The WAN IP address will be located under Networking Status > IP Address. Unplug the laptop / pc. 

 
Now that you have the WAN IP address, you must log into the web panel. Open your browser and point it to 
http://[WANIPADDRESS]. 

 
 
 
 
 
 
 
 
 
On the login screen, the default username and password is 
“admin”. Press the LOGIN button to enter the MicroPBX web 
panel. 
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2.2 Configuring VoIP SIP Credentials 
 
Navigation: Settings > Configutration: This is where you setup your SIP Credentials.  
 

 
 

If you are using ALLO.COM as your VoIP provider: 
 

• Under the VoIP Network configuration section, make sure the “Connect to ALLO.COM” option is checked. 
Input your ALLO.COM VoIP username and password.  

 

 
 
If you are using a 3rd party VoIP provider: 
 

• Under the VoIP Network configuration submenu, ensure that “Connect to ALLO.COM” is unchecked, and fill in 
Proxy Address, Proxy Port, Username, Password and Realm information given to you by your VoIP provider.  
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Hit the Update button to apply the changes. An orange “Apply changes” button will 
appear at the top-right hand corner, if it wasn’t there already. Press this button. 
 

 
 
 
 
The page will then display a progress screen: 
 

 
 
 
2.3 Checking Registration 
 
To ensure successful registration, you must click the “Status” button on the top menu.  
 
 

 
 
 
Under “VoIP Registration Status” you will see the server status. If it displays “Registered” then it is successfully 
configured. If it displays anything else, redo step 2.2. 
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3. Setting Up Features 
 
3.1 Extensions 
 
3.1.1 What is an Extension? 
 
Extensions are the core of the MicroPBX. 
 
This is pretty straight forward. An extension is a number mapped to a person. So basically, every employee that is 
connected to the MicroPBX should have their own extension number, so that he/she can be reached, and be able to 
place calls. 
 

 
 
 
An Extension can be part of other features, such as: Call Groups, Queues, Voicemail Groups, etc. Also, the extension 
can have a voicemail of its own.  
 
With Allo.com’s MicroPBX, you can create up to 30 extensions. 
 
3.1.2 Configuring an Extension 
 
Navigation: Extensions > Create Extension: This is where you setup your extensions.  
 

 
 
 
General Information 

1. Extension #: Unique identifier (eg: 201) 
2. Password: the password for the extension 

(eg: 201) 
3. Description: a short description of the 

extension 
4. First & Last Name: the first and last name 

of the person to be used as Caller ID 
5. Login Username: the username for the 

person to access their web panel 
6. Login Password: the password for the 

person to access their web panel 
 

 
 



 

 7

 
Extension Properties 

1. Queue: makes the extension available when creating a Queue 
2. Directory Service: makes the extension available in the Directory Service 
3. Call Group: makes the extension available when creating a Call Group 
4. Voicemail Group: makes the extension available when creating a Voicemail Group 
5. Roam Extension: Enables the extension to be accessible from anywhere in the world using the ALLO.COM 

network just as if it were on the local LAN. Use only when required. 
 

 
 
Voicemail Alert 

1. e-mail: the email address of the user of the extension 
2. Notify: enable this if you wish to be notified by email when a new voicemail is received 
3. Attach Voicemail: enable this if you wish to receive the voicemail in WAV format as an email attachment. Notify 

has to be enabled. 
 

 
 
ATA Provisioning 
The MicroPBX can auto configure an ALLO.COM ATA. 
 

1. MAC: enter the WAN MAC address of the ALLO.COM ATA 
a. Phone1: configures Phone1 port with the current extension 
b. Phone2: configures Phone2 port with the current extension 
c. Line & Bridge: allows the MicroPBX to dial out using this ATA’s PSTN line 

 

 
 
Voicemail PIN Number 
The PIN number to retrieve voicemail messages for this extension. 
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Call Forwarding 
Forwards an incoming call to this extension to any phone number. It can be PSTN, cellular, National or International 
number. 
 

 
 
3.2 Queue 
 
3.2.1 What is a Queue? 
 
A Queue is a series of calls waiting on hold to be answered. Calls are answered according to their order of arrival, first 
in first out. A Queue is composed of one or many extensions. 
 
3.2.2 Configuring a Queue 
 
Navigation: Queue > Create Queue: This is where you setup your Queues. 
 
 

 
 
 
Queue Details 

1. Queue Name: the name of the Queue 
2. Queue Type:  

a. Ring All: rings all available extensions 
b. Round Robin: takes turns ringing each available extension 
c. Least Recent: rings the extension which was least recently called by this queue 
d. Fewest Calls: rings the extension with fewest complete calls from this queue 
e. Random: rings a random extension 
f. Round Robin Memory: performs a Round Robin remembering where we left off with the last ring pass 

3. Max Queue Length: the maximum number of callers waiting in queue for an available representative. 
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Announce Options 
1. Announce Hold Time: announces an estimated hold time to the caller in queue 
2. Announce Frequency: how often a caller is announced of his/her position in queue 
3. Wrap-Up Time: after a call is finished, the time it takes an extension to become available again 

 

 
 
List of Available Members 
The list of available members that could be part of this queue 
 

 
 
Members 

1. Priority: the frequency a member is sought out to answer the incoming call 
 

 
 
 
3.3 Call Group 
 
3.3.1 What is a Call Group? 
 
A Call Group is a pre-programmed group of call recipients (extensions) that ring at the same time. 
 
3.3.2 Configuring a Call Group 
 
Navigation: Extensions > Call Group: This is where you setup your Call Groups 
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Create a New Call Group 

1. Call Group Name: the name of the Call Group 
2. Available Members: the list of available extensions that could be part of this Call Group 
3. Members in Group: the list of extensions that belong to this Call Group 

 

 
 
 
3.4 Voicemail Group 
 
3.4.1 What is a Voicemail Group? 
 
A Voicemail Group is a pre-programmed group of voicemail recipients. All the members of this group will receive the 
same voicemail message. 
 
3.4.2 Configuring a Voicemail Group 
 
Navigation: Extensions > Voicemail Group: This is where you setup your Voicemail Groups 
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Create a New Voicemail Group 
1. Voicemail Group Name: the name of the Voicemail Group 
2. Available Members: the list of available extensions that could be part of this Voicemail Group 
3. Members in Group: the list of extensions that belong to this Voicemail Group 

 
 

 
 
3.5 Call Parking 
 
3.5.1 What is Call Parking? 
 
Call Parking is an advanced version of On Hold. 
 
3.5.2 Configuring Call Parking 
 
Navigation: Extensions > Call Parking: This is where you setup your Call Parking 
 

 
 
 
Change Call Parking Settings 

1. Range: The amount of placeholders dedicated to park calls. 
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3.6 Conference 
 
3.6.1 What is a Conference? 
 
A Conference is a virtual space where meetings can be held with unlimited participants. It is managed by a virtual 
operator.  
 
3.6.2 Configuring a Conference 
 
Navigation: Extensions > Conference: This is where you setup your Conference rooms 
 

 
 
Create a New Conference Room 

1. Room Number: the number of the room 
2. Private: if enabled, the conference is password protected 
3. PIN: a numeric password used to enter a private conference 
4. Admin PIN: a numeric password to administer a private conference 

 

 
 
3.7 DID Routing 
 
3.7.1 What is a DID? 
 
A DID is an incoming phone number.  
 
DID Routing is a feature that enables incoming calls to be routed directly to selected stations without attendant 
assistance. 
 
3.7.2 Configuring DID Routing 
 
Navigation: Extensions > DID Routing: This is where you setup your DID Routing 
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Create a New DID 

1. DID Number: a virtual number associated with your VoIP service 
2. Link DID to a Station: when enabled, all incoming calls through this DID are going to be redirected to the 

selected station 
 

 
 
3.8 Music on Hold 
 
3.8.1 What is Music on Hold? 
 
Music on Hold is the pre-recorded music which fills the silence that would be heard by telephone callers that have been 
placed on hold. 
 
3.8.2 Configuring Music on Hold 
 
Navigation: IVR > Music on Hold: This is where you setup Music on Hold 
 
 

 
 

 
Upload New Music File 

1. Select File: by pressing the “Browse” button, you can navigate your local PC to locate an audio file in mp3 
format. 
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3.9 Voicemail Operator 
 
3.9.1 What is a Voicemail Operator? 
 
A Voicemail Operator is an interactive wizard which guides you to fetch your voicemail. The default number to dial is 
800. 
 
3.9.2 Configuring a Voicemail Operator 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Voicemail Operator: This is where you 
setup your Voicemail Operator 
 

 
 
 
3.10 Conference Operator 
 
3.10.1 What is a Conference Operator? 
 
A Conference Operator is an interactive wizard which guides you to join a conference. The default number to dial is 
700. 
 
3.10.2 Configure a Conference Operator 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Conference Operator: This is where you 
setup your Conference Operator 
 
 
3.11 Directory Service 
 
3.11.1 What is Directory Service? 
 
Directory Service is an interactive wizard which guides you to reach the correct extension by inputting the first three 
letters of the last name. 
 
3.11.2 Configuring Directory Service 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Directory Service: This is where you 
enable or disable your Directory Service. When enabled, it appears as an option in the Creation of IVR screen. 
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3.12 Blind Transfer 
 
3.12.1 What is Blind Transfer? 
 
Blind Transfer is when a call is transferred to an extension without announcing the transfer to the recipient. To use this 
feature in a conversation, press #[Prefix] – the default prefix is #2. 
 
3.12.2 Configuring Blind Transfer 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Blind Transfer: This is where you 
configure Blind Transfer.  
 
 
3.13 Attended Transfer 
 
3.13.1 What is Attended Transfer? 
 
Attended Transfer is when a call is transferred to an extension while announcing the transfer to the recipient. To use 
this feature in a conversation, press #[Prefix] – the default prefix is #3. 
 
3.13.2 Configuring Attended Transfer 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Attended Transfer: This is where you 
configure Attended Transfer. 
 
 
3.14 Dial Out 
 
3.14.1 What is Dial Out? 
 
Dial Out is the prefix to dial when making an outgoing call using VoIP. The default prefix is 9. 
 
3.14.2 Configuring Dial Out 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Dial Out: This is where you configure Dial 
Out. 
 
 
3.15 Dial Bridge 
 
3.15.1 What is Dial Bridge? 
 
Dial Bridge is the prefix to dial when making an outgoing call using the ATA’s PSTN port specified in an Extension. The 
default prefix is 8. 
 
3.15.2 Configuring Dial Bridge 
 
Navigation: Settings > Configuration > Prefixes and Directory Service > Dial Bridge: This is where you configure 
Dial Bridge. 
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4. Setting Up the Interactive Voice Response (IVR) 
 
4.1 Voice Files 
 
4.1.1 What are Voice Files? 
 
Voice Files are the pre-recorded audio files that are going to be played during the IVR playback. These files can be 
recorded with any audio recording software, or by hiring a Voice Talent. 
 
Example:  
 

“Welcome to ACME Corp! If you know your party’s extension, please dial it now.  
Press 1 for Customer Service 
Press 2 for Billing 
Press 3 for Shipping” 

 
4.1.2 Configuring Voice Files 
 
Navigation: IVR > Voice Files: This is where you setup your Voice Files 
 
 

 
 

 
 
Upload New Voice File 

1. Select File: by pressing the “Browse” button, you can navigate your local PC to locate a pre-recorded voice file 
in WAV format. 

2. Description: a small description of the file 
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4.2 Create IVR 
 
4.2.1 What is an IVR? 
 
An IVR is a pre-recorded interactive operator defined by a sequence of actions that provides a customer with a better 
call experience. An IVR can be ‘chained’ with other IVR’s creating a multi-level IVR system.  
 
Example:  
 

“Welcome to ACME Corp! If you know your party’s extension, please dial it now.  
Press 1 for Customer Service 
Press 2 for Billing 
Press 3 for Shipping” 
 

Customer presses 1 for Customer Service, triggering a new IVR: 
 
Example: 
 

“Press 1 for Residential Service 
Press 2 for Business Service” 

 
IVR’s can be sent to any other feature, such as: Extensions, Queues, Call Groups, Voicemail Groups, Conference 
Operator, etc. 
 
4.2.2 Configuring an IVR 
 
General Information 

1. Name: the name of the IVR 
 

 
 
 
Sequences > Add Sequence:  

1. Step: the order in which the sequences are going to be triggered 
2. Type: the type of sequence 

a. Answer The Call: answers the call 
b. Playback With Keypress: plays an audio file reacting to the keypress of the caller 
c. Playback Without Keypress: plays an audio file without reacting to the keypress of the caller 
d. Wait: waits a certain amount of seconds 
e. Hang Up The Call: hangs up the call 
f. Loop This IVR: start this IVR from step 1 
g. Dial an Extension: automatically dials an extension specified 
h. Allow Caller to Dial an Extension: allows a caller to dial an extension while the IVR is being played 
i. Launch Directory Service: a virtual operator that helps the caller reach the correct extension by 

spelling out the last name 
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Keypress Options > Add Keypress:  
1. Number: the number to be pressed 
2. Go To: the type of station to be connected to. Only the available features are visible 

 

 
 
4.3 IVR Schedules 
 
4.3.1 What is an IVR Schedule? 
 
An IVR Schedule allows an IVR to be played at a specific time. You can create multiple schedules, and play different 
IVR’s based on specific times. 
 
4.3.2 Configuring IVR Schedules 
 
Navigation: IVR > IVR Schedules: This is where you setup your IVR Schedules 
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Create a Schedule 
1. Name: the name of the schedule 
2. Description: a short description of the schedule 
3. IVR Menu: the IVR menu to be triggered 
4. Day Range: the days to play the IVR Schedule 
5. Time Range: the hours within the Day Range to play the IVR Schedule 

 
 

 
 
4.4 Time Configuration 
 
4.4.1 What is Time Configuration? 
 
Time Configuration is the local time settings of the MicroPBX. It is used to trigger different IVR Schedules. 
 
4.4.2 Configuring Time Configuration 
 
Navigation: Settings > Configuration > Time Configuration: this is where you setup your Time Configuration 
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5. Networking 
 
Networking occurs anytime you connect two or more computers together so that they can share resources. 
 
Navigation: Settings > Networking: This is where you setup your Networking Configuration 
 
 

 
 
 
5.1 WAN Configuration 
 
5.1.1 What is WAN Configuration? 
 
WAN Configuration is the Internet settings of your MicroPBX. 
 
5.1.2 Configuring WAN Settings 
 
Navigation: Settings > Networking > WAN Configuration: This is where you setup your WAN Configuration 
 
WAN Configuration 

1. DHCP: when enabled and a DHCP server is available, the MicroPBX will auto configure itself. If DHCP is not 
available, select Disable, and fill in the Network Configuration 

2. IP Address: the IP address corresponding to your LAN configuration* 
3. Netmask: the Netmask corresponding to your LAN configuration* 
4. Gateway: the IP address corresponding to your Gateway* 
5. DNS 1: the IP address corresponding to a DNS server* 
6. DNS 2: the IP address corresponding to a DNS server* 

 

 
 

*Contact your Network Administrator for this information 
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5.2 LAN Configuration 
 
5.2.1 What is LAN Configuration? 
 
Use this setting in the event that you want to use the MicroPBX as your network router. 
 
5.2.2 LAN Configuration 
 
Navigation: Settings > Networking > LAN Configuration: This is where you setup your LAN Configuration 
 
LAN Configuration 

1. IP Address: the IP address corresponding to your LAN configuration* 
2. Netmask: the Netmask corresponding to your LAN configuration* 
3. DHCP IP Start: the first IP in the lease range* 
4. DHCP Leases: the number of leases allowed* 

 

 
 
*Contact your Network Administrator for this information 
 
5.3 Host Configuration 
 
5.3.1 What is Host Configuration? 
 
Host Configuration is used to manage your MicroPBX’s Host Name and Domain Name. 
 
5..2 Host Configuration 
 
Navigation: Settings > Networking > Host Configuration: This is where you setup your Host Configuration 
 
Host Configuration 

1. Host Name: the name of the device inside the network 
2. Domain Name: the workgroup name 
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6. Glossary of Terms 
 
 
ALLO.COM 
Allo.com is a VoIP provider and the developer of the MicroPBX. Visit http://www.allo.com for more information. 
 
ATA 
Analog Telephone Adapter: Used to connect a standard telephone to a high-speed modem to facilitate VoIP and/or fax calls over the Internet. 
 
CHANNEL 
A transmission path between two points. It is usually the smallest subdivision of a transmission system by means of which a single type of 
communications service is provided. 
 
DHCP 
Short for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses to devices on a network. With dynamic addressing, a 
device can have a different IP address every time it connects to the network. DHCP also supports a mix of static and dynamic IP addresses. 
 
DID 
Direct Inward Dial. A specially configured phone line from the telephone company that allows for dialing inside a company directly without having to 
go through an attendant. A DID line cannot be used for outdial operation since there is no dialtone offered. However, it can be configured so an 
outside caller can reach an inside extension with a 7-digit number through the phone company's central office. 
 
DNS 
The Domain Name System is the system that translates Internet domain names into IP numbers. A "DNS Server" is a server that performs this kind 
of translation. 
 
GATEWAY 
A network point that acts as an entrance to another network. 
 
IP ADDRESS 
Every machine that is on a network (a local network, or the network of the Internet) has a unique IP number [four sets of numbers divided by period 
with up to three numbers in each set. (ie 192.168.0.100)] - If a machine does not have an IP address it cannot be on a network. 
 
IVR 
Interactive Voice Response: A system to automatically manage incoming calls, IVR can link phone callers (voice and/or touchtone) with a computer 
database. It can accept a question, access the company's database and provide a caller with the information they are seeking. It can also take 
information from the caller, convert it to data and input that data to the database. 
 
LAN 
Local Area Network: A LAN is a group of computers and associated devices that share a common communications line or wireless link and typically 
share the resources of a single processor or server within a small geographic area (for example, within an office building). 
 
NETMASK 
Used by the TCP/IP protocol to decide how the network is broken up into sub-networks (ex: 255.255.255.0). 
 
PBX 
Private Branch Exchange: An in-house telephone switching system that interconnects telephone extensions to each other, as well as to the outside 
telephone network. 
 
PROXY 
A server that receives requests intended for another server and that acts on the behalf of the client behalf (as the client proxy) to obtain the 
requested service. A proxy server is often used when the client and the server are incompatible for direct connection. For example, the client is 
unable to meet the security authentication requirements of the server but should be permitted some  
 
SIP 
Session Initiation Protocol: An application-layer control protocol, a Signaling protocol for Internet Telephony. SIP can establish sessions for features 
such as audio/videoconferencing, interactive gaming, and call forwarding to be deployed over IP networks thus enabling service providers to 
integrate basic IP telephony services with Web, e-mail, and chat services. In addition to user authentication, redirect and registration services, SIP 
Server supports traditional telephony features such as personal mobility, time-of-day routing and call forwarding based on the geographical location 
of the person being called. 
 
PSTN 
Public Switched Telephone Network: This is defined as the regular telephone network. 
services. 
 
VOIP 
Voice over Internet Protocol. The technology used to transmit voice conversations over a data network using the Internet Protocol. Such data 
network may be the Internet or a corporate Intranet. 
 
WAN 
Stands for Wide Area Network. A computer network that spans a relatively large geographical area. Typically, a WAN consists of two or more local-
area networks (LANs). 
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